Monday, November 23, 2009

Windows 7 M17x/Dell pop-up/preview/tooltip windows dissapearing quickly bug

Seems some Dell/Alienware have an issue with Windows 7. After some unknown (yet) operation, all the:
- windows with preview forms
- tooltips
- windows taskbar preview
- Visual studio intellisense and other debug info hover windows
- alt tab switching previews
- systray preview windows
...simply dissapear very quickly after they are shown. (the most annoying being the debug popups dissapearing).

Single solution found on the internet, was a system restart with a laptop reset (take battery out and power cable, press power button 3 seconds, put it back and start the laptop).

I didn't knew first what is causing this(BIOS maybe from internet sources), my Alienware M17X is also affected, I have seen many others affected by this too, surprisingly(or not) all with Dell machines.

Later edit: This issue annoyed me so much I started killing processes that don't have anything to do with Windows 7. After killing OSD_Main, Alien FX Hook manager (both 32 bit x86 and x64) the popup dissapearings were gone. So the BIOS shit has nothing to do with it, probably the hook managers are acting normally at system restart.

Later later edit: Nope, still no luck, started again. Now killed everything until I ended up with 6 services running and like 5-10 window processes needed to avoid a windows restart, uninstalled all custom drivers that might affect performance. Until I re-enabled hybrid mode for graphics from BIOS it didn't worked. This might as well count as a BIOS reset I guess. So go figure...

Bye.

PS: One colleague pinpointed to me another Windows7 bug. If you craft a share server and return some bogus data intentionally, the windows kernel enters an eternal loop, killing your computer.

2 comments:

krisvek said...

any progress on this? I too have been driven insane by this

Cosmin said...

Well it didn't made such thing for me for a long time. I have updated to A03 BIOS version and using NVIDIA 186.40 drivers, and it doesn't make like that anymore. Try using DPC latency checker too to see if you have driver problems: http://www.thesycon.de/deu/latency_check.shtml